import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "DeviceXYZ.+$";
final String string = "Building1-Lab1-DeviceABC1\n"
+ "Building1-Lab1-DeviceABC2\n"
+ "Building1-Lab1-DeviceXYZ1\n\n"
+ "Building1-Lab2-DeviceABC1\n"
+ "Building1-Lab2-DeviceABC2\n"
+ "Building1-Lab2-DeviceXYZ1\n\n"
+ "Building2-Lab1-DeviceABC1\n"
+ "Building2-Lab1-DeviceABC2\n"
+ "Building2-Lab1-DeviceXYZ1\n\n"
+ "Building2-Lab2-DeviceABC1\n"
+ "Building2-Lab2-DeviceABC2\n"
+ "Building2-Lab2-DeviceXYZ1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}