package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Redirecting to .*?\?from=(?P<from>[\.a-z0-9]+)&exportFileName=(?P<exportFileName>[\.a-z0-9]+)(?:&to=(?P<to>[\.a-z0-9]+))?(?:\&lang=(?P<lang>[a-z]+))?(?:\&action=(?P<action>[a-z\-]+))?`)
var str = `Redirecting to /en/replacementOverview/?from=fa1e3273f2a2e5e8771dbd1ac8d0883f.xml&exportFileName=source.en.xlf&to=f2c3513085b9bda6012e5ce48e46a38d.xml&lang=de&action=overview-test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}