# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Redirecting to .*?\?from=(?P<from>[\.a-z0-9]+)&exportFileName=(?P<exportFileName>[\.a-z0-9]+)(?:&to=(?P<to>[\.a-z0-9]+))?(?:\&lang=(?P<lang>[a-z]+))?(?:\&action=(?P<action>[a-z\-]+))?"
test_str = "Redirecting to /en/replacementOverview/?from=fa1e3273f2a2e5e8771dbd1ac8d0883f.xml&exportFileName=source.en.xlf&to=f2c3513085b9bda6012e5ce48e46a38d.xml&lang=de&action=overview-test"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.