const regex = /Redirecting to .*?\?from=(?P<from>[\.a-z0-9]+)&exportFileName=(?P<exportFileName>[\.a-z0-9]+)(?:&to=(?P<to>[\.a-z0-9]+))?(?:\&lang=(?P<lang>[a-z]+))?(?:\&action=(?P<action>[a-z\-]+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Redirecting to .*?\\?from=(?P<from>[\\.a-z0-9]+)&exportFileName=(?P<exportFileName>[\\.a-z0-9]+)(?:&to=(?P<to>[\\.a-z0-9]+))?(?:\\&lang=(?P<lang>[a-z]+))?(?:\\&action=(?P<action>[a-z\\-]+))?', 'g')
const str = `Redirecting to /en/replacementOverview/?from=fa1e3273f2a2e5e8771dbd1ac8d0883f.xml&exportFileName=source.en.xlf&to=f2c3513085b9bda6012e5ce48e46a38d.xml&lang=de&action=overview-test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}