import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Redirecting to .*?\\?from=(?P<from>[\\.a-z0-9]+)&exportFileName=(?P<exportFileName>[\\.a-z0-9]+)(?:&to=(?P<to>[\\.a-z0-9]+))?(?:\\&lang=(?P<lang>[a-z]+))?(?:\\&action=(?P<action>[a-z\\-]+))?";
final String string = "Redirecting to /en/replacementOverview/?from=fa1e3273f2a2e5e8771dbd1ac8d0883f.xml&exportFileName=source.en.xlf&to=f2c3513085b9bda6012e5ce48e46a38d.xml&lang=de&action=overview-test";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}