import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "span id=\"(.*)\" style=\"width:0px;\"> *<\\/span>.*?-(.*)";
final String string = "<p><span id=\"XL\" style=\"width:0px;\"> </span>XL - <a class=\"external text\" href=\"https://w.amazon.com/index.php/Amazon%20XL%20-%203P%20Heavy%20Bulky%20with%20Services\" rel=\"nofollow\"</p>zon XL</a>, aka Unified Heavy/Bulky with Services\n"
+ "<p><span id=\"XLR\" style=\"width:0px;\"> </span>XLR - AB UX Leadership Review (<a class=\"external text\" href=\"https://quip-amazon.com/Q0MxAQlIvbrR\" rel=\"nofollow\">1</a> <a class=\"exter</p>text\" href=\"https://quip-amazon.com/dVPrAHLgg2hJ\" rel=\"nofollow\">2</a> <a class=\"external text\" href=\"https://quip-amazon.com/dVPrAHLgg2hJ#bNS9CAAGh1S\" rel=\"nofollow\">3</a>)\n"
+ "</p>span id=\"XML\" style=\"width:0px;\"> </span>XML - <a class=\"external text\" href=\"http://en.wikipedia.org/wiki/XML\" rel=\"nofollow\">Extensible Markup Language</a>\n"
+ "</p>span id=\"XPF\" style=\"width:0px;\"> </span>XPF - Cross Platform\n"
+ "</p>span id=\"XRD\" style=\"width:0px;\"> </span>XRD - Cross-Functional Response Document\n"
+ "</p>span id=\"XRP\" style=\"width:0px;\"> </span>XRP - Cross-Region Peering\n"
+ "</div><h2><span class=\"mw-headline\" id=\"Y\">Y</span></h2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}