const regex = /span id="(.*)" style="width:0px;"> *<\/span>.*?-(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('span id="(.*)" style="width:0px;"> *<\\\/span>.*?-(.*)', 'gm')
const str = `<p><span id="XL" style="width:0px;"> </span>XL - <a class="external text" href="https://w.amazon.com/index.php/Amazon%20XL%20-%203P%20Heavy%20Bulky%20with%20Services" rel="nofollow"</p>zon XL</a>, aka Unified Heavy/Bulky with Services
<p><span id="XLR" style="width:0px;"> </span>XLR - AB UX Leadership Review (<a class="external text" href="https://quip-amazon.com/Q0MxAQlIvbrR" rel="nofollow">1</a> <a class="exter</p>text" href="https://quip-amazon.com/dVPrAHLgg2hJ" rel="nofollow">2</a> <a class="external text" href="https://quip-amazon.com/dVPrAHLgg2hJ#bNS9CAAGh1S" rel="nofollow">3</a>)
</p>span id="XML" style="width:0px;"> </span>XML - <a class="external text" href="http://en.wikipedia.org/wiki/XML" rel="nofollow">Extensible Markup Language</a>
</p>span id="XPF" style="width:0px;"> </span>XPF - Cross Platform
</p>span id="XRD" style="width:0px;"> </span>XRD - Cross-Functional Response Document
</p>span id="XRP" style="width:0px;"> </span>XRP - Cross-Region Peering
</div><h2><span class="mw-headline" id="Y">Y</span></h2>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}