using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,3} (?<PartNum>.*?)\n(?<Description>(?:.|\n)+?)(?:(?=^\d{1,3})|(?![\s\S]))";
string input = @"1 HUY-12
Description line 1 for the HUY-12
2 JIU-14
Description line 1 for the JIU-14
This one has 2 lines of description
3 KOI-10
Description line 1 for the KOI-10
Second description line
Third description line
4 GYT4
Description line 1 for the GYT4";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}