const regex = new RegExp('^\\d{1,3} (?<PartNum>.*?)\\n(?<Description>(?:.|\\n)+?)(?:(?=^\\d{1,3})|(?![\\s\\S]))', 'gmi')
const str = `1 HUY-12
Description line 1 for the HUY-12
2 JIU-14
Description line 1 for the JIU-14
This one has 2 lines of description
3 KOI-10
Description line 1 for the KOI-10
Second description line
Third description line
4 GYT4
Description line 1 for the GYT4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}