import Foundation
let pattern = #"^\d{1,3} (?<PartNum>.*?)\n(?<Description>(?:.|\n)+?)(?:(?=^\d{1,3})|(?![\s\S]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
1 HUY-12
Description line 1 for the HUY-12
2 JIU-14
Description line 1 for the JIU-14
This one has 2 lines of description
3 KOI-10
Description line 1 for the KOI-10
Second description line
Third description line
4 GYT4
Description line 1 for the GYT4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)