use strict;
my $str = '1 HUY-12
Description line 1 for the HUY-12
2 JIU-14
Description line 1 for the JIU-14
This one has 2 lines of description
3 KOI-10
Description line 1 for the KOI-10
Second description line
Third description line
4 GYT4
Description line 1 for the GYT4';
my $regex = qr/^\d{1,3} (?<PartNum>.*?)\n(?<Description>(?:.|\n)+?)(?:(?=^\d{1,3})|(?![\s\S]))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}