package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)[a-z][0-9]{3}-[0-9]{3}S[0-9]{4}N[0-9]{4}`)
var str = `I123-123S1234N1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}