const regex = /(?i)[a-z][0-9]{3}-[0-9]{3}S[0-9]{4}N[0-9]{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)[a-z][0-9]{3}-[0-9]{3}S[0-9]{4}N[0-9]{4}', 'gm')
const str = `I123-123S1234N1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}