// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)[a-z][0-9]{3}-[0-9]{3}S[0-9]{4}N[0-9]{4}").unwrap();
let string = "I123-123S1234N1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}