$re = '/(?i)[a-z][0-9]{3}-[0-9]{3}S[0-9]{4}N[0-9]{4}/m';
$str = 'I123-123S1234N1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);