using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(!!!|\?\?\?|asap|formula help|google sheets help|help me out|help!|looking for help|need help|noob|please help|pls help)";
string input = @"please help me calculate compound interest
How do I send a pivot table in a sheet to an email using scripts? (help a noob)
Getting importXML to work???";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}