$re = '/(!!!|\?\?\?|asap|formula help|google sheets help|help me out|help!|looking for help|need help|noob|please help|pls help)/mi';
$str = 'please help me calculate compound interest
How do I send a pivot table in a sheet to an email using scripts? (help a noob)
Getting importXML to work???';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);