// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(!!!|\?\?\?|asap|formula help|google sheets help|help me out|help!|looking for help|need help|noob|please help|pls help)").unwrap();
let string = "please help me calculate compound interest
How do I send a pivot table in a sheet to an email using scripts? (help a noob)
Getting importXML to work???";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}