#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9][0-9]{4,}$"
Local $sString = "12345" & @CRLF & _
"1234" & @CRLF & _
"12345678900000" & @CRLF & _
"1234.10" & @CRLF & _
"12345.10" & @CRLF & _
"100" & @CRLF & _
"101.50" & @CRLF & _
"2000" & @CRLF & _
"3000.30" & @CRLF & _
"0...000..." & @CRLF & _
"000000.0000000" & @CRLF & _
"0004" & @CRLF & _
"2222" & @CRLF & _
"9999" & @CRLF & _
"10000 " & @CRLF & _
"200001" & @CRLF & _
"100000" & @CRLF & _
"1000.00" & @CRLF & _
"100001" & @CRLF & _
"3000.30" & @CRLF & _
"100.00 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")