re = /^[1-9][0-9]{4,}$/m
str = '12345
1234
12345678900000
1234.10
12345.10
100
101.50
2000
3000.30
0...000...
000000.0000000
0004
2222
9999
10000
200001
100000
1000.00
100001
3000.30
100.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end