use strict;
my $str = '12345
1234
12345678900000
1234.10
12345.10
100
101.50
2000
3000.30
0...000...
000000.0000000
0004
2222
9999
10000
200001
100000
1000.00
100001
3000.30
100.00
';
my $regex = qr/^[1-9][0-9]{4,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}