using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9][0-9]{4,}$";
string input = @"12345
1234
12345678900000
1234.10
12345.10
100
101.50
2000
3000.30
0...000...
000000.0000000
0004
2222
9999
10000
200001
100000
1000.00
100001
3000.30
100.00
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}