use strict;
my $str = '<a href="/rss/images/" target="_blank"><img src="/themes/blooper/footer_rss.png" alt="RSS" title="RSS"></a>,<a href="https://t.me/blooper" target="_blank"><img src="/themes/blooper/footer_telegram.png?t=1" alt="Telegram" title="Telegram"></a>,<a href="https://discord.gg/lit" target="_blank"><img src="/themes/blooper/footer_discord.png?t=1" alt="Discord" title="Discord"></a>,<a href="http://blooper.media/"><img src="/themes/blooper/blooper.png" alt="blooper.media" title="blooper.media"></a>';
my $regex = qr/<a href="(.*?) target/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}