// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)<a href="(.*?) target"#).unwrap();
let string = "<a href=\"/rss/images/\" target=\"_blank\"><img src=\"/themes/blooper/footer_rss.png\" alt=\"RSS\" title=\"RSS\"></a>,<a href=\"https://t.me/blooper\" target=\"_blank\"><img src=\"/themes/blooper/footer_telegram.png?t=1\" alt=\"Telegram\" title=\"Telegram\"></a>,<a href=\"https://discord.gg/lit\" target=\"_blank\"><img src=\"/themes/blooper/footer_discord.png?t=1\" alt=\"Discord\" title=\"Discord\"></a>,<a href=\"http://blooper.media/\"><img src=\"/themes/blooper/blooper.png\" alt=\"blooper.media\" title=\"blooper.media\"></a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}