import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img class=\\\"my-page__icon-img\\\" src=\\\"([^\"]+)\\\"";
final String string = "<img class=\"my-page__icon-img\" src=\"https://site.com/static/icons/vector/some.svg\" alt=\"Img\" width=\"40\" height=\"40\">\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}