$re = '/<img class=\"my-page__icon-img\" src=\"([^"]+)\"/';
$str = '<img class="my-page__icon-img" src="https://site.com/static/icons/vector/some.svg" alt="Img" width="40" height="40">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);