// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img class=\"my-page__icon-img\" src=\"([^"]+)\""#).unwrap();
let string = "<img class=\"my-page__icon-img\" src=\"https://site.com/static/icons/vector/some.svg\" alt=\"Img\" width=\"40\" height=\"40\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}