const regex = /<img class=\"my-page__icon-img\" src=\"([^"]+)\"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img class=\\"my-page__icon-img\\" src=\\"([^"]+)\\"', 'g')
const str = `<img class="my-page__icon-img" src="https://site.com/static/icons/vector/some.svg" alt="Img" width="40" height="40">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}