using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[А-ЯЁ][^А-ЯЁ]*";
string input = @"Получать каждый деньНе получать оповещенияПолучать каждый часПолучать каждый деньЁолучать еженедельно";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}