// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[А-ЯЁ][^А-ЯЁ]*").unwrap();
let string = "Получать каждый деньНе получать оповещенияПолучать каждый часПолучать каждый деньЁолучать еженедельно";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}