$re = '/[А-ЯЁ][^А-ЯЁ]*/';
$str = 'Получать каждый деньНе получать оповещенияПолучать каждый часПолучать каждый деньЁолучать еженедельно';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);