package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[А-ЯЁ][^А-ЯЁ]*`)
var str = `Получать каждый деньНе получать оповещенияПолучать каждый часПолучать каждый деньЁолучать еженедельно`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}