package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\Q[]\E]`)
var str = `[]s`
var substitution = "replaced"
fmt.Println(re.ReplaceAllString(str, substitution))
}