import Foundation
let pattern = #"[^\Q[]\E]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[]s"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replaced"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)