const regex = /[^\Q[]\E]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\Q[]\\E]', 'gm')
const str = `[]s`;
const subst = `replaced`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);