$re = '/[^\Q[]\E]/m';
$str = '[]s';
$subst = "replaced";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;