$re = '/int+\s*[a-zA-Z]+\s*\(\s*+[a-zA-Z]+\s*(,+\s*+[a-zA-Z]+\s*)*\)/m';
$str = 'int sum ( int , int)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);