re = /int+\s*[a-zA-Z]+\s*\(\s*+[a-zA-Z]+\s*(,+\s*+[a-zA-Z]+\s*)*\)/m
str = 'int sum ( int , int)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end