using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^а-яёa-z0-9\s\.]";
string input = @"""Бастилия"" по мотивам картины К. Коровина
~Бастилия~ по мотивам картины К. Коровина
№Бастилия№ по мотивам картины К. Коровина";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}