package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[^а-яёa-z0-9\s\.]`)
var str = `"Бастилия" по мотивам картины К. Коровина
~Бастилия~ по мотивам картины К. Коровина
№Бастилия№ по мотивам картины К. Коровина`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}