re = /[^а-яёa-z0-9\s\.]/mi
str = '"Бастилия" по мотивам картины К. Коровина
~Бастилия~ по мотивам картины К. Коровина
№Бастилия№ по мотивам картины К. Коровина'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end