$re = '/[^а-яёa-z0-9\s\.]/miu';
$str = '"Бастилия" по мотивам картины К. Коровина
~Бастилия~ по мотивам картины К. Коровина
№Бастилия№ по мотивам картины К. К оровина';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);