# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(([A-Z]+)-([0-9]+))\[([A-Z]+)-([A-Z0-9-]+)(\])/\1 \4/gm;t' <<< "PSHELF-2[PSHELF-MF-6RU]
SHELF-5[SHELF-M6]
SHELF-6[SHELF-M15]
SHELF-6[SHELF-M15]"