use strict;
my $str = 'PSHELF-2[PSHELF-MF-6RU]
SHELF-5[SHELF-M6]
SHELF-6[SHELF-M15]
SHELF-6[SHELF-M15]';
my $regex = qr/(([A-Z]+)-([0-9]+))\[([A-Z]+)-([A-Z0-9-]+)(\])/mp;
my $subst = '\\1 \\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";