using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]{1}[a-z]{2,15}\s[A-Z]{1}[a-z]{2,15}$";
string input = @"Arnel Jose";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}