import Foundation
let pattern = #"^[A-Z]{1}[a-z]{2,15}\s[A-Z]{1}[a-z]{2,15}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Arnel Jose"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}