package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Z]{1}[a-z]{2,15}\s[A-Z]{1}[a-z]{2,15}$`)
var str = `Arnel Jose`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}