using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\s[^>]*>[^<]*<\/a>)";
string input = @"If you <a href='https://example.com'>Click here</a> then <a href='https://example.net'>Click here</a>.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}