re = /(<a\s[^>]*>[^<]*<\/a>)/m
str = 'If you <a href=\'https://example.com\'>Click here</a> then <a href=\'https://example.net\'>Click here</a>.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end