package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a\s[^>]*>[^<]*<\/a>)`)
var str = `If you <a href='https://example.com'>Click here</a> then <a href='https://example.net'>Click here</a>.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}